Thanks for letting me know! Fixed in this patch.
True, though having two separate methods for this (and then maybe a third for marks) also seems overkill. Would renaming it to
setNodeMarkup work for you? (‘markup’ is already used as a term for the set of node type, attributes, and marks in