The website examples in github failed to build

Hi. I am a back-end developer in somewhere of Asia. I tried to build our company’s custom editor using prosemirror. I think this is Interesting challenge.

So I got this source from github.

– That repo info –

Then I did steps in

But It is failed during “make” command after “npm install”. The warning/error message is next below.

make all --debug

  • make:cli Make init CLI with env namespace success name options +0ms*
  • make:cli Run all targets +4ms* make i info Invoking all target
  • make:cli Prerequities "$(subst .md,.html,$(PAGES:pages/%=public/%)) " for target all +2ms*
  • make:cli Emit target:unknown +1ms*
  • make:cli Handled true +2ms* (node:412988) UnhandledPromiseRejectionWarning: undefined (node:412988) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). (rejection id: 1) (node:412988) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code. make × ERR not found: make-$(subst
  • make:cli Load templates from 3 directories +27ms*
  • make:cli Load templates from C:\Users\buptle\AppData\Roaming\npm\node_modules\make\templates +1ms*

I figured out that The node.js didn’t take ‘UnhandledPromiseRejection’ anymore. How can i fix this? I tried add some “catch” code. but Originally I’m not a front-end developer unfortunately and this is still failed.

I would appreciate any advice. (and sorry for my poor English)

and version info node -> v10.1.0, npm -> 5.6.0, make -> 0.8.1,

If I downgrade the “make” command is there possible to success on build?

I think you’ve got the wrong make — the website build is using GNU make, the Unix tool, not the npm package called make.

Thanks for your reply. I will check your advice.

Hi. marijn, I did GNU make command on centos 7 and It seems that something still go wrong. Can I get any clue about this?


Weird. make is running the right command, but somehow src/build/build.js is choking on the basic example (which is the first file it tries to build) when looking for the metadata written as a JSON object at the top of the file. This is working fine on my platform and I can’t really think of any reason it would fail elsewhere. You could try to debug it, if you have the time.