Versioning for core modules


#1

I have tried to RTFM, so apologies in advance if I’ve missed something obvious.

If I pull the latest prosemirror repo and run ‘bin/pm install’, the core modules that are installed are quite out of date. As an example, I end up with prosemirror-view@^0.22.0, which is probably 40 releases behind the latest.

What am I doing wrong?

I’m also confused by some of the examples. I’m playing around with the ‘PM track changes’ example. That repo doesn’t seem to include the core modules. Is it just that that example is using an older version of PM where functionality wasn’t yet split into the core modules?

Thanks in advance!


#2

bin/pm install clones the master branch of the repositories on github, so I can’t explain how that could possibly get your version 0.22.0.

The examples all use the latest code. What do you mean the repo doesn’t ‘include’ the core modules? The examples live in the website repository, whose package.json depends on all the core modules that the examples use.


#3

Marijn, thanks for all of your work on this project, and for the quick response. I think I was confused about a few issues, and there isn’t actually any problem. When I ran ‘bin/pm install’, yarn.lock showed 0.22.1, as per snippet below, but I later realized that the actual repo in the view/ directory was the latest. Maybe that makes sense to you?

   prosemirror-view@^0.22.0:
      version "0.22.1"
      resolved "https://registry.yarnpkg.com/prosemirror-view/-/prosemirror-view-0.22.1.tgz#1e945c625531472fb817483b101de85a018593b5"
      dependencies:
        prosemirror-model "^0.22.0"
        prosemirror-state "^0.22.0"
        prosemirror-transform "^0.22.0"

And then in regards to the track changes example, I should have been clearer. I thought this (https://github.com/newsdev/prosemirror-change-tracking-prototype) was the repo for the project’s ‘track changes’ example. But this sample repo appears to be using a much older version of prosemirror that I’m guessing was perhaps before you split out the core modules (?).

Thanks again for your help.


#4

Right, I’m seeing those in my yarn.lock too—it seems prosemirror-gapcursor depends on an old version of prosemirror-tables for no reason whatsoever, and that’s pulling in those old core library versions (under gapcursor/node_modules). This patch fixes that.


#5

Thanks marijn. When I re-installed, that did indeed remove the dependencies from the yarn.lock, although as I think you figured out, I had misinterpreted what the version numbers in the original yarn.lock meant, and I actually had the latest core modules all along.

Thanks, Jon